On Sun, Dec 8, 2019 at 5:29 AM fmiser <fmiser@gmail.com> wrote:
> > fmiser wrote:
> >
> > I'm having troubles with configuration, setup, running.  I have
> > been using SQL-Ledger for many years but now I must update... 

> By commenting out the line "LISTEN_ADDRESS=localhost" (and
> restarting the ledgersmb service, i.e. Starman), Starman will
> bind to all available interfaces, allowing access from other IP
> addresses and machines than just the local one. That should at
> least get you up and running being able to access the system.

Well, it did not work.

So then I ran dpkg-reconfigure and told it to NOT setup for Apache
as a Web Reverse Proxy (which I had done earlier)  Now I cannot
even connect using links2.
browser error " refused to connect."

Hmm. I didn't understand that this worked before. I thought you were logging into the machine using SSH and then using lynx or links2. Do you have any idea if there's a firewall in place which may be blocking port 5762? (or maybe all ports except e.g. 22, 80 and/or 443?)
Apache error, "not found"

Well, now that you "unconfigured" the reverse proxy I guess the above is to be expected: the reverse proxy setup should make sure the above works through some extra apache configuration.
However, if I log in over SSH, links2 works if I use localhost

but not if I use the IP address.

Next I tried using the IP address rather than just commenting out the "listen_address" in /etc/default/ledgersmb

Ok. But did you try the situation with the commented-out


Same errors as above

Should I be concluding that you get no error with links2 over http://localhost:5762/login.pl from the last remark ("same errors as above")? or does that stop working? If it kept working after changing the IP, my main question would be: did you restart the ledgersmb service after you edited /etc/default/ledgersmb ?

Also, which version of Debian did you install? I saw above that you said "fresh installation of Debian", but is that Buster or Stretch or Sid or ...? If this is Buster, I think we might be banging on the wrong door: in that case, we probably should be looking in the "ledgersmb.service" (or something named like it) file to change the starman startup parameters. I don't have a Debian 10 handy right now, so if you let me know which Debian version, I'll spin one up and see what the package looks like in installed form (note that Jaime maintains the package; I just know how to analyse it).




http://efficito.com -- Hosted accounting and ERP.
Robust and Flexible. No vendor lock-in.